Project

General

Profile

Bug #442

F200 filter

Added by Jeffrey Painter about 8 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Category:
QC_data_checker
Start date:
09/14/2011
Due date:
% Done:

0%

Estimated time:

Description

This is a feature suggestion, not a bug.

The majority of the F200 (constant value in record) warnings which I have seen, have been for record 0. I think that a F200 warning for record 0 is almost certain to be spurious, and hence should be suppressed. The reason is that record 0 is often the initial value for a model run, and it is a common practice to initialize some of a model’s variables with “unphysical” values such as a constant - the correct value will be computed after the first time step. That is, although the data is not physically correct, it is entirely as intended and cannot be considered to be an error.

For my own purposes I wrote (in Python) a filter to read the QC tool’s output and eliminate all F200 warnings for record 0. I think this sort of thing also could be done in the QC tool itself.

History

#1 Updated by Heinz-Dieter Hollweg about 8 years ago

  • Status changed from New to Feedback
  • Assignee set to Heinz-Dieter Hollweg

I don’t think that such a filter should be part of the QC checks, because due to the immense number of variables, users
don’t know in general which first record is initially set constant by intention and which is not.
There is a utility, xtractFlags_from.log, in QC/scripts for post-processing, which extracts just those entries from
the log-files in 'experiment_logs’ that contain thrown flags. Optionally, you can exclude specific flags like e.g. F200
from the extraction by a comma-separated-list of flags. The result is written into the new sub-directory _Flags.

Regards, hdh

#2 Updated by Heinz-Dieter Hollweg over 6 years ago

  • Status changed from Feedback to Resolved

Done with QC-0.4 Revision 5263

Also available in: Atom PDF